Resolved
We handled the changes for SFL Investments. Please try syncing again.
Monitoring
The fix for SFL Investments has been published. Please try connecting again and let us know if you run into issues.
Investigating
We are aware that the login page for SFL Investments has changed, and our team is working on implementing these changes. We will update this page with all developments.