·
Resolved
No components marked as affected
Investigating
We are investigating an incident where users are not able to add new investments