Resolved
This issue is now resolved.
Monitoring
We are investigating further reports of long loading times. Our team is working to improve the dashboard speed.
Resolved
This is now resolved.
Monitoring
Users may experience longer loading for the next 20-30 mins due to infrastructure redeployment. Thank you for your understanding.
Resolved
This issue is now resolved
Identified
The issue has been identified and the system will be redeployed in the next 20-30 minutes. Thank you for your patience.
Investigating
The dashboard may not load for some users. Our team is investigating this currently and will resolve this as soon as possible.