Resolved
We have replaced Yodlee's BMO with our own Core version. Please add the core version of BMO Online Banking to your dashboard.
Identified
We have not received an update from Yodlee for their BMO Online Banking Connector. Wealthica's data team has built a connector in-house that is working well. Please use the new BMO Online Banking CORE version available view the +ADD and search or via the link: https://app.wealthica.com/dashboard/add-investment/financial/bmoobweb
Identified
Yodlee has provided an update that their engineering team continues to work on handling MFA from BMO Online Banking.
Investigating
Yodlee has reported an issue with BMO MFA handling. Accounts with MFA enabled will have issues connecting with a technical error. We will update this page with developments.