Wealthica

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Manulife VIP Room, Connection Issue
Monitoring·Partial outage

We have pushed new fixes to this connector. More fixes may be required in order to resolve this issue, but we need some users to test our fix. Please try reconnecting and provide feedback to hello@wealthica.com.

Thu, Mar 26, 2026, 04:39 PM
(2 months ago)
·
Affected components
Mar 26, 2026, 04:39 PM
Now
Updates

Monitoring

We have pushed new fixes to this connector. More fixes may be required in order to resolve this issue, but we need some users to test our fix. Please try reconnecting and provide feedback to hello@wealthica.com.

Thu, Mar 26, 2026, 04:39 PM

Investigating

We are aware of syncing issues with Manulife VIP Room. Please follow this incident to get updates.

Thu, Mar 26, 2026, 04:39 PM