Monitoring
We have pushed new fixes to this connector. More fixes may be required in order to resolve this issue, but we need some users to test our fix. Please try reconnecting and provide feedback to hello@wealthica.com.
Investigating
Select connection attempts are experiencing a timeout. We are investigating this issue.